mardi, mai 04, 2010

0.7.3 > 0.9.4 > 0.9.5

Fin janvier, j'étais bloqué dans le développement de mon level editor. par un bug crapuleux de desmume 0.9.4 (version par défaut dans Karmic Koala) qui m'empèchait d'utiliser le touchscreen dans mes dernières productions. J'avais heureusement toujours les sources de la version 0.7.3 (qui, elle, fonctionne sans soucis de ce côté) sous la main.

Là, je viens de réinstaller Lucid Lynx sur Beetle et rebelote pour les soucis: l'EFS de Noda essaie de fonctionner en mode "DLDI" plutôt qu'en mode "GBA".

I'm stuck to desmume-cli version 0.7.3 on my Ubuntu alambics... Karmic Koala ships a 0.9.4 release that somehow ignores clicks on the touchscreen ... 0.9.5 shipped with Lucid Lynx is even worse: it seems to misunderstand EFS attempts to read the ROM file through GBA slot (a technique known as "NitroFS", afaik) and falls back to DLDI-powered crawl through a (non-existant) filesystem. I filed a bug report on the desmume sourceforge project ... Hope it'll be of some help.

Edit: some tip from Ludo: install 0.9.6 and use desmume-cli --gbaslot-rom=mybrew.nds mybrew.nds

2 commentaires:

Ludo6431 a dit…

Salut,
par défaut le fichier nds n'est pas chargé en RAM gba dans la dernière 0.9.5, il faut pour cela le spécifier en ligne de commande.

Il faut par exemple faire :

desmume --gbaslot-rom=file.nds file.nds

et là tu pourras exécuter ton homebrew en EFS je pense.

Il y a cependant un autre soucis, desmume n'est pas compilé par défaut avec cette option sous linux :/
J'avais essayé de le recompiler depuis les sources mais j'avais eu quelques soucis, je vais réessayer et te tenir au courant.

++, Ludovic

sylvainulg a dit…

J'avais vu cette option-là dans la version "svn" qui ne parvenait malheureusement pas à faire tourner mon homebrew ... Elle est présente dans la 0.9.6, en revanche. A défaut d'être pratique à taper, c'est jouable.

Merci pour le tuyau ^_^
Longue vie à tes homebrews _\\//